Phobos II


OVERVIEW


£15

Immediate download after checkout

Requires full version of Native Instruments Kontakt 5.8.1 or higher



phobos-1
phobos-3
phobos-4
phobos-2
previous arrow
next arrow
phobos-1
phobos-3
phobos-4
phobos-2
previous arrow
next arrow

SPECIFICATION

DEMO